[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Gnash-dev] "Couldn't find plugin for video type video/x-h264! Please ma

From: scott092707
Subject: [Gnash-dev] "Couldn't find plugin for video type video/x-h264! Please make sure you have gstreamer-ffmpeg installed."
Date: Thu, 13 Nov 2014 13:02:41 -0500

I get the above error when trying to play an yout ube video, after I installed Lubuntu 14.10.

The sound plays, and the stored video contains the video as well, as it is fully playble by smplayer.

I find notes to the effect that I could not find "
gstreamer0.10-ffmpeg" when I installed Lubuntu 14.04.
At that time, I could get it by installing the
repository., but  there is some problem now, either with finding the pkg, or installing it, perhaps because
I am not using trusty anymore, but
I have tried to find it elsewhere, but without success.
Supposedly it is superceded by gst-libav (sp?) but Ihave not had luck with that as well (several days ago), and could not
find it or maybe install it, or it did not work - I don't remember (sorry).

If anyone has solved this problem and knows the solution, please let me know.

If what I tried should have worked, I will try again, and do a better job of documenting my attempt(s)...

Thank you.


uname -a
Linux scott-ASUS-M2N68-AM-PLUS 3.16.0-24-generic #32-Ubuntu SMP Tue Oct 28 13:13:18 UTC 2014 i686 athlon i686 GNU/Linux
address@hidden:~$ lsb_release -dsc
Ubuntu 14.10
address@hidden:~$ echo $DESKTOP_SESSION

gnash --version
Gnash 0.8.11dev (master-2-070912d)

Copyright (C) 2005, 2006, 2007, 2008, 2009, 2010, 2011, 2012, 2013 Free Software Foundation, Inc.
Gnash comes with NO WARRANTY, to the extent permitted by law.
You may redistribute copies of Gnash under the terms of the GNU General
Public License.  For more information, see the file named COPYING.

Build options
   Renderers: agg cairo
   Hardware Acceleration: none
   Media handlers: gst ffmpeg
   Configured with: --host=i686-linux-gnu --build=i686-linux-gnu --prefix=/usr --sysconfdir=/etc --enable-testsuite --without-swfdec-testsuite --disable-dependency-tracking --disable-rpath --enable-cygnal --enable-python --enable-media=gst,ffmpeg --enable-gui=gtk,qt4,dump --enable-renderer=agg,cairo --enable-docbook --enable-extensions=fileio,lirc,mysql --with-npapi-plugindir=/usr/lib/gnash --with-plugins-install=system --enable-shared=yes
   CXXFLAGS: -g -O2 -fPIE -fstack-protector-strong -Wformat -Werror=format-security -Wall          -W     -Wall     -Wcast-qual     -Wpointer-arith     -Wreturn-type     -Wnon-virtual-dtor     -Wunused      -fvisibility-inlines-hidden -fPIE -fstack-protector --param ssp-buffer-size=4 -Wformat -Werror=format-security

Config options altered:
set MediaHandler gst   (there was a problem with videos never loading when was ffmpeg when I had Lubuntu 14.04)
set saveStreamingMedia true
set saveLoadedMedia false
set mediaDir /data/scott/gnash_media
set debuglog /data/scott/gnash-dbg.log

reply via email to

[Prev in Thread] Current Thread [Next in Thread]