[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

6310i and bluetooth problems

From: anne
Subject: 6310i and bluetooth problems
Date: Fri, 4 Jul 2003 12:53:11 +1000

Hi All.

After trawling the archives of this list, and trying everything I
could find that looked relevant, I'm finally mailing to the list to
see if someone can tell me what I'm doing wrong.

I have a Nokia 6310i, a d-link dbt-120 USB-Bluetooth adaptor, and
a Debian Linux Testing/Unstable mix with a custom 2.4.21 kernel. When
I run gnokii --monitor I get:  

GNOKII Version 0.5.2
Opened configuration file /root/.gnokiirc
Added new section global
Adding key/value port/00:60:57:46:B8:4A
Adding key/value model/6310i
Adding key/value initlength/default
Adding key/value connection/bluetooth
Adding key/value bindir//usr/local/sbin/
Adding key/value use_locking/no
Adding key/value serial_baudrate/19200
Adding key/value smsc_timeout/10
Added new section connect_script
Adding key/value TELEPHONE/12345678
Added new section disconnect_script
phone instance config:
model: 6310i
port_device: 00:60:57:46:B8:4A
connection_type: 5
init_length: 0
serial_baudrate: 19200
serial_write_usleep: -1
hardware_handshake: 0
require_dcd: 0
smsc_timeout: 100
Serial device: opening device 00:60:57:46:B8:4A
Couldn't open PHONET device: Success
Error in link initialisation: 1
Telephone interface init failed: Command failed.
Serial device: closing device

I have compiled gnokii with debugging, hoping that would give me some
useful information. (BTW make gnokii-debug, which the README suggests,
isn't a valid target). My .gnokiirc settings can be seen above, but
I've tried lots of variations on these with no success (sometimes I
get different text instead of Success on the PHONET line).

Bluetooth itself seems to be working fine though I've no other devices
to test it with:

>hcitool scan
Scanning ...
        00:60:57:46:B8:4A       Anne Nokia

hcitool cc also seems to work, as do any rfcomm commands for which I
manage to get the syntax correct. ;-)

A program called multisync (from Debian unstable) can connect to the
phone and gets to the point of exchanging PINs. I understand multisync
isn't compatible with the 6310i with the modules I currently have, so
that's as far as it gets, but I tried it to check the bluetooth

Some other output that might be useful:
Module                  Size  Used by    Not tainted
l2cap                  13856   2  (autoclean)
rfcomm                 27136   0  (autoclean)
hci_usb                 6080   1  (autoclean)
bluez                  27136   3  (autoclean) [l2cap rfcomm hci_usb]
parport_pc             11812   1  (autoclean)
lp                      6016   0  (autoclean)
parport                12928   1  (autoclean) [parport_pc lp]
serial_cb               1204   1 
tulip_cb               32000   2 
cb_enabler              2720   4  [serial_cb tulip_cb]
ds                      6880   4  [cb_enabler]
i82365                 27280   2 
pcmcia_core            41376   0  [cb_enabler ds i82365]
uhci                   23592   0  (unused)

>ps ax  (output heavily trimmed)
  509 ?         S       0:00 hcid: processing events
  515 ?         SW      0:00 [krfcommd]
  519 ?         S       0:00 /usr/sbin/sdpd

I am happy to try and provide any other information that anyone thinks
might help to sort out what's wrong. I found a few emails on the list
archives that mentioned similar problems, but either the fixes
suggested there didn't work, or the thread pettered out without an


reply via email to

[Prev in Thread] Current Thread [Next in Thread]