[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: pin help

From: Pawel Kot
Subject: Re: pin help
Date: Mon, 19 Mar 2007 18:11:18 +0100


On 3/19/07, Timothy Murphy <address@hidden> wrote:
On Wed 07 Feb 2007, Pawel Kot wrote:

> > I can't help you, but I definitely think there should be a gnokii
> > PIN-HOWTO, as this evidently causes many people problems.

I looked at this page,
but unfortunately found it almost useless.

I am sorry. I am unable to write anything better. There's everything I
needed to run in under ubuntu.

I have a new computer, and have spent a couple of hours
trying to set up bluetooth (bluez),
and in particular trying to set the bluetooth pin on the computer,

In brief, when I say "gnokii --identify" my phone (a Sony-Ericsson T630)
asks for the pin number, and whatever I enter it responds "Passkey mismatch".
So I take it I have not set the pin correctly on my computer.

Not set. Entered. Whenever the PC side initiates the connection, some
popup window with passkey prompt should appear. The whole thing is to
let it appear. Alternatively you may hardcode passkey in the
pin_helper script.

I have the appropriate number in /etc/bluetooth/pin .
(This file is owned by root, and has permission-mode 644.)

This is irrelevant. AFAIR bluez does not use this file for outgoing connections.

I have tried various pin-helpers in /etc/bluetooth/hcid.conf:

        # pin_helper dbus_pin_helper;
        pin_helper /usr/bin/bluez-pin;
        # pin_helper /etc/bluetooth/

And what does /usr/bin/bluez-pin script does?

In the last case reads:
echo "0000"

I also tried 'echo "PIN:0000".

The latter should work.

The instructions on the given page include
address@hidden:~$ bluez-bin --dbus &

It starts the bluetooth pin deamon listening for DBUS events. If it
receives PIN request, it should popup a window (if everything is
correctly configured).

address@hidden:~$ sudo /etc/init.d/bluez-utils restart

This is not needed in most cases. And that's Debian style.

I assume the first command should read "bluez-pin"?

Right. I'll fix it.

In any case, I gave that command.
Also I have no file /etc/init.d/bluez-utils on my Fedora-6 system
(with all bluez* packages installed).
I do have a bluetooth service, and run "sudo service bluetooth restart"
after each change.

That would be the way for RH systems.

So I would repeat the question:
How exactly does one set the bluetooth PIN on a computer under bluez?

I am afraid I cannot give more detailed instruction. I'll try to find
some fresh system and configure it. Maybe there's more information on
Bluez project site.

take care,
Pawel Kot

reply via email to

[Prev in Thread] Current Thread [Next in Thread]