[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Partial AT command support ? Return from experience...

From: sani . broyeur
Subject: Partial AT command support ? Return from experience...
Date: Thu, 01 Jul 2010 10:56:04 +0200
User-agent: Internet Messaging Program (IMP) 3.2.8

Hi all.

I use a Nokia 7230 connected to a Linux 2.6.32 box for environmental data
collection thru custom scripts and gnokii-smsd "action" scheme.

With bluetooth, it works like a charm, with the simplest config:

model = AT
connection = bluetooth
port = aa:bb: . . .

Unfortunately, bluetooth drains A LOT from the battery when not on mains via a
AC charger, and prevent the use of EM shield between the phone and the Linux

So I bought a genuine Nokia CA-126 USB cable, suitable for this model, that
provides both USB connectivity and 3mm power plug. The Nokia 7230 is said to be
a full featured GSM for data access, and AT/Modem compatible.

I modified the gnokiirc accordingly:

model = AT
connection = serial
port = /dev/ttyACM0

This config works with a... LG viewty, but this is not the same story :-)

Here it goes wrong:

1) Once plugged in USB, udev identifies a serial class devices, and creates a
/dev/ttyACM0 device. This is the normal behaviour.

2) With a terminal emulator on /dev/ttyACM0, simple AT commands are recognized
and answered. This phone has a kind of AT modem emulation.

3) First test: "gnokii --sendsms" works great, the phone reacts perfectely.

4) Second test: an SMS is send to the Nokia 7230, and gnokii-smsd crashes when
trying to read the phone, with the exact config that worked with bluetooth!

5) Back to terminal emulator, and issue of AT commands related to SMS reading:
ERROR for all!

-> It seems that AT command set is very partial when accessing the phone by
USB/serial cable, despite this AT command set is complete with bluetooth.

Am I right ?!?

So I decided to bypass the AT mode and use F-BUS:

1) I blacklisted all acm_* related kernel drivers to prevent udev from creating
/dev/ttyACMx devices and let the usb devices available for other code.

2) I Modified the gnokiirc as instructed @

model = series40
port = 1
connection = dku2libusb

3) tried gnokii --identify which gave errors and hanged :-(

I would add that the cable is probabely a passive one, since modifying the 7230
behaviour thru its menu ("PC suite" | "Print" | "Storage") is immediately seen
thru USB behaviour, and that unplugging the phone from the cable is accordingly
detected in /var/log/messages.

Two questions at end :-)

- Is it correct to state that AT command set could be affected by the
communication port, i.e full featured with bluetooth and restricted with cable ?

- Is there a known way to bypass this and use the genuine CA-126 nokia cable to
prevent bluetooth use ?


reply via email to

[Prev in Thread] Current Thread [Next in Thread]