[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Gnu-arch-users] New user - building on Cygwin

From: Karl Waclawek
Subject: Re: [Gnu-arch-users] New user - building on Cygwin
Date: Mon, 15 Sep 2003 11:51:27 -0400

> On Sun, Sep 14, 2003 at 12:02:49 -0400, Karl Waclawek wrote:
> > 
> > More feed back on make test under Cygwin:
> >  
> > > - create separate "build" directory (parallel to src)
> > > - cd to this directory
> > > - run ../src/configure --with-cc gcc --config-shell /bin/bash
> > > - run make 
> > > 
> > > Which works fine. Then I ran make test and got errors, the same
> > > as in the archived message, i.e. for the "fs-tests" directory
> > > (the error messages not telling me much),
> > 
> > Main problem was: ~/ expandion did not work right.
> > Reason: In Cygwin, sh maps to ash, not bash.
> > Once I pointed sh to bash this test worked fine.
> > 
> > Question: Except for these tests, is tla sensitive
> > to the fact that sh really is ash and not bash under Cygwin?
> sh is really ash on my linux too and everything works all right, so no,
> it's not.
> IIRC tla does not use a shell at all.
> Btw, after resolving this problem, does it seem that tla works under
> Cygwin?

I did start the tutorial, and it seems to work OK, no crashes.
One thing (so far) that does *not* work is setting the tagging method.
It reports a file permission error. This can be solved (after the error
happened) by deleting the file =tagging-method and renaming the temporary 
file ,,tagging-method to =tagging-method.

Btw, the tutorial does not seem to reflect the actual default behaviour
for the tagging method, since inventory --source returns nothing
(default tagging method is explicit), when the tutorial says it should
return the files in the example.

I will try to practice more at the end of the week.
If I run into problems I will report them here.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]