[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Gnu-arch-users] Broken trees?

From: Jean Helou
Subject: Re: [Gnu-arch-users] Broken trees?
Date: Tue, 27 Apr 2004 16:17:27 +0200
User-agent: Mozilla Thunderbird 0.5 (X11/20040306)

Frederic Gedin a écrit :

Jean Helou a écrit :

Frederic Gedin a écrit :


I am facing a strange situation and I don't know how to fix it. I develop either on my desktop or on my laptop. On the desktop, I have an archive which contains the version "aida--main--0.1". On the laptop, I have an archive which contains the version "aida--laptop--0.1". Today I am unable to report changes made on the laptop into the desktop development tree. The star-merge command gives me the following error message:
star-merge: unable to merge unrelated trees.

If I understand correctly, you say you have :
aida--main--0.1, on your desktop
aida--laptop--0.1, on your laptop tagged from aida--main--0.1

and then you say you have a development tree on your desktop. If that tree isn't aida--main--0.1, but instead is something like :

aida--anything--0.1 , tagged from aida--main--0.1 (wild guess)

Actually no.  I develop directly in aida--main--0.1, on the desktop.

Then the (current) star-merge algorithm won't detect that aida--laptop--0.1 and aida--anything--0.1 do have a common ancestor, because that ancestor is located in aida--main--0.1.

I once had this problem too, two solutions :
-make a replay/update from laptop to devo ( or devo to laptop doesn't matter) so they have a common ancestor. -use the "-r, --reference VERSION" option to star-merge.

I tried without any success. However, you give me the right cause: the update comands on the desktop gives me the following message "update: tree has no common history with version".

The problem is unfortunately not symetric: on the laptop the star-merge with aida--main--0.1 works fine but on the desktop the star-merge with aida--laptop--0.1 doesn't. So apparently the laptop knows that aida--laptop--0.1 has aida--main--0.1 as an ancestor but the desktop doesn't.

So the question is, how can I set/check the common ancestor of two versions?

You can check the ancestry using "tla ancestry" and "tla ancestry-graph". Once the details of the problem are exposed, it should be easier to correct it.

Btw, I wonder how hard it would be to go past tag boundary to find a common ancestor. Has anyone thought/tried to do something about it ?

Sorry for not being mature enough on tla to help you there :'(

No problem here, I intended this as a more open question to every one on the ML but hit the wrong button . My bad.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]