[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Gnu-arch-users] botched invariant

From: James Blackwell
Subject: Re: [Gnu-arch-users] botched invariant
Date: Mon, 13 Sep 2004 17:16:09 -0400

John Meinel wrote:
> address@hidden/mifar-pocky--dev--0.7--patch-69
> /users/jfmeinel/dev/other/tla/tla-1.2.2rc1/src/tla/libarch/library-txn.c:492:botched
> invariant
>      !replay_status
> PANIC: exiting on botched invariant
> This is being run with tla 1.2.2rc1.
> Does anyone know what this invariant is, and why it would be botched? I 
> can send the change in question, but it is also available on 

Yeah. This invariant is in the library code, looking for an ancestor
revision in the library. That leads me to a (possibly oversimplified)
conclusion that your library is pooched somehow.

Try removing that archive, category, branch or version from your library
and see if the problem is solved then.

> These patches were probably generated by leroy's tla-1.2.1--dirname on 
> win32, so that might be the problem.

If you're adding (as yet) unsupported patches, then the correct way to
route this is through Lode first, and if he declares that its not his
code, then to come to us.

> Basically, it happens any time I try to update from that tree. I am 
> using a revision library.
> I've worked around it by doing a cachrev on my other machine, so that it 
> doesn't try to update across that patch.
> Can anyone help me out? I'm going to sleep now, but I'll be back in 
> about 8 hours.

James Blackwell          Try something fun: For the next 24 hours, give
Smile more!              each person you meet a compliment!

GnuPG (ID 06357400) AAE4 8C76 58DA 5902 761D  247A 8A55 DA73 0635 7400

reply via email to

[Prev in Thread] Current Thread [Next in Thread]