[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Gnu-arch-users] Unable to 'tla get' from public mirror -- PANIC: I/

From: maillists
Subject: Re: [Gnu-arch-users] Unable to 'tla get' from public mirror -- PANIC: I/O error
Date: Wed, 15 Sep 2004 15:39:56 +0200 (CEST)

On Wed, 15 Sep 2004, Aaron Bentley wrote:

One solution would be for get to use the official name, and succeed. Another would be for it to note the name mismatch and fail. I think the second is probably better, because after you fixed 'get', there'd be a plethora of other commands to fix, and after you fixed all the commands, the payoff would be quite small. Having get fail with a clearer error "Cannot use foo because it is registered with the wrong name. Please register it as bar" would stop people from going too far down the wrong path.

What do other people think?

YES, PLEASE. It took me yesterday a few hours till I saw, that I accidently registered a mirror of a collegue of mine with a different alias. tla get worked like a charm but when I tried to tla missing it showed me that all 120 patches were still not applied. tla update of course refused to work at all: trees are not related. A warning would be nice.


Ingo Buescher <address@hidden>
"The whole aim of practical politics is to keep the populace alarmed
(and hence clamorous to be led to safety), by menacing it with an
endless series of hobgoblins, all of them imaginary." -- H. L. Mencken

reply via email to

[Prev in Thread] Current Thread [Next in Thread]