[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Gnumed-devel] help on bootstaping gnumed cvs

From: Alessandro Amici
Subject: Re: [Gnumed-devel] help on bootstaping gnumed cvs
Date: Mon, 25 Oct 2004 17:14:16 +0200
User-agent: KMail/1.6.2


On Monday 25 October 2004 12:53, Alessandro Amici wrote:
> > b) you can use the account "any-doc"
> i tried test-doc, any-doc and test-nurse, all fail with the same error
> message.

ok, i re-bootstraped the cvs in a more or less reproducible way, here is what 
i did:
$ cd /somepath
$ cvs co gnumed
# ln -s /somepath/gnumed/gnumed/client /usr/lib/python2.3/site-packages/Gnumed
# vi /etc/pg_hba.conf   # add at the beginning 'local all all trust' and
    # 'host all all trust'
# /etc/init.d/posgresql reload
$ cd /somepath/gnumed/gnumed/server/bootstrap
$ cp bootstrap-monolithic_core.conf bootstrap-gm_db_system.conf
# cd /somepath/gnumed/gnumed/server/bootstrap
# ./

at this point i still get the "The database account [test-doc] is not 
associated with any staff member known to GnuMed." error for all identities.

# su postgres
$ psql gnumed < ../sql/test-data/test_data-Leonard_McCoy.sql

_now_ i can log in as test-doc and any-doc :)

i've been not able to do much after log in, but at least i've seen the main 
window ;-)

unless i did something very wrong, the following things were very hard to find 
and definitely need a fix:
- the --conf option appears to be broken (you need to cp the .conf file to one 
of the hardcoded ones)
- the bootstrap script should load some test data together with the test 


reply via email to

[Prev in Thread] Current Thread [Next in Thread]