[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Gnumed-devel] the (wxwidgets) 2.6 issue

From: Karsten Hilbert
Subject: Re: [Gnumed-devel] the (wxwidgets) 2.6 issue
Date: Thu, 23 Jun 2005 20:15:39 +0200
User-agent: Mutt/

> So in the meantime from an "attempting user" point of view, I have 
> gotten Linux Debian (Sarge) installed on the desktop machine
That should put you in one of the best possible situations
regarding installing/running GNUmed.

> If that distro should happen to have 2.4, is there any risk that 
> higher versions (2.5x, 2.6) could become part of "newer" versions of 
> Sarge,
Yes, that "risk" is there.

> so I would have to be careful if there is any such thing on 
> Debian as "maintenance" or other "updates" to Sarge that I should 
> want/need to do from time to time?
Yes and no. Yes because if you allow the upgrade as soon as it
is available GNUmed may not be up to the task (eg 2.6) yet.
OTOH since I run Sarge there's a good chance Sarge will run
GNUmed no matter what upgrades are done to Sarge itself.

> If the distro should happen to have 2.5x/2.6, I assume it can be 
> removed with impunity and replaced by 2.4 if all I want to do is to 
> run GNUmed, but as per the above would I be prone to 2.5x/2.6 getting 
> re-installed during any Debian "updating"? Is there a file or 
> application I should look to customize to prevent that?
It is possible to "pin down" a version of a package if that
should really be necessary. However, 2.6 appearing in Sarge
would be a rather tell-tale sign for 2.6 becoming widespread
at which point we should increase our efforts to support it.

Note that *supporting* (as in "also running on") is very
different from taking advantage of all of it (as in "not
anymore running on anything below 2.6"). The former will
happen, the latter will have to wait for quite a while.

GPG key ID E4071346 @
E167 67FD A291 2BEA 73BD  4537 78B9 A9F9 E407 1346

reply via email to

[Prev in Thread] Current Thread [Next in Thread]