[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Gnumed-devel] gmClinical.sql and general comments

From: Karsten Hilbert
Subject: Re: [Gnumed-devel] gmClinical.sql and general comments
Date: Thu, 12 Jan 2006 12:45:28 +0100
User-agent: Mutt/1.5.11

On Thu, Jan 12, 2006 at 10:02:01AM +1100, Richard wrote:

> However in regard to naming conventions I'd suggest the following
> gm + schema + table + whatever.
We only started using schemata post-0.1. And only recently
did we move to extensive use of them. If you want us to go
through this pain now, fine, I am with you. I am all for
tidy names.

> Though I'm not sure I like the nomenclature for the Static etc,
What's your suggestion, then, on that ?

> at least now you have explained it I understand why you
> have separated it into static and dynamic.
Good. I don't really care about the name per se, just about
the separation - and then an "intuitive" name for that.

> Also with table definitions, because of  the inconsistancies in your table 
> names they dont' sit together often in the database structure.
There is no such thing as "sit together" in relational
databases. Operating with such concepts bears the danger of
misunderstanding RDBMSs.

To understand the database structure - as in how it is
interrelated - one is supposed to generate an ER model
representation. Either explicitely - as we provide on the
Wiki as a PNG - or implicitely in one's head - which I have
done for too long.

Don't work on the *names* as scapegoats for relationships.
Down that road peril lies. Work on the relationships. The
Japanese say that it's the moon, not the finger that's
pointing upwards.

Nevertheless I agree with you that speaking names are very
useful. I am simply too lazy to type "vaccination" where I
could simply type "vacc". Also your assertion that PG does
not limit identified length does not hold true. Unless you
recompiled PG with name_len=maxint. The limit is 63

> vaccination_link_bla bla
It's a Holy War whether

 fk_other_table or other_table_fk
 vaccination_link or lnk_vaccination

> one should aim to make things more readable.
But also it needs to remain writable.

> Same with shema's schema clinical is much better than clin, or demographics, 
> instead of dem, or configuration instead of cfg or administration instead of 
> admin.

 select currval('clinical.vaccination_link_regimes_to_indications_pk_seq');

Is that what you want ?

> There is no reason to use short names.
There is a difference between "speaking" and "clad in
verbiage". And there are practical hard limits.

GPG key ID E4071346 @
E167 67FD A291 2BEA 73BD  4537 78B9 A9F9 E407 1346

reply via email to

[Prev in Thread] Current Thread [Next in Thread]