[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [GNUnet-developers] Make "gnunet-arm -e" not hang

From: Christian Grothoff
Subject: Re: [GNUnet-developers] Make "gnunet-arm -e" not hang
Date: Sat, 28 Sep 2019 22:40:26 +0200
User-agent: Mozilla/5.0 (X11; Linux x86_64; rv:60.0) Gecko/20100101 Thunderbird/60.9.0

If you get the "GNUNET_CLIENT_test()" symbol undefined, then somehow
you're not linking against the 'right' (latest) libgnunetutil. Maybe you
have two installations on your system, and the linker finds the wrong
one? Please make sure you only have one libgnunetutil installed, then
this should work.

On 9/28/19 10:31 PM, Alessio Vanni wrote:
> xrs <address@hidden> writes:
>> Seems to work. Thank you!
> It's the opposite for me, instead.
> If I run "gnunet-arm -s" the program hangs even though the services are
> running.  On the other hand, "gnunet-arm -e" says the
> `GNUNET_CLIENT_test' symbol is undefined.  The hang happens for any flag
> that is not "-e".
> I tried reinstalling GNUnet, including rerunning "autoconf -fi",
> rebuilding the ld cache and even rebooting, but it didn't fix the
> problem.  I can't tell if I did something wrong, what might've happened
> and what should I do?
> Thanks,
> A.V.
> _______________________________________________
> GNUnet-developers mailing list
> address@hidden

Attachment: signature.asc
Description: OpenPGP digital signature

reply via email to

[Prev in Thread] Current Thread [Next in Thread]