[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[gpsd-dev] Has anybody tried the SiRF S4?

From: Hal Murray
Subject: [gpsd-dev] Has anybody tried the SiRF S4?
Date: Tue, 11 Mar 2014 23:30:15 -0700

I saw a comment about them someplace so I ordered one.

I'm testing a GlobalSat BU-353S4  (USB)
So far, not great.

It's a bit more sensitive than a SiRF 3 in a similar location.

Playing with gpsmon, I can't get it to change baud rate.
It often ends up non-responsive:
  Neither gpsmon nor gpsd will talk to it.
  Power cycle fixes things.

I think I saw a similar problem when trying to switch from SiRF binary to 

It starts at 4800, NMEA.
gpsmon can switch to SiRF mode.
gpsd/ntpd/shm only gets 1/2 to 3/4 of the samples.

Is SiRF mode, gpsmon says:
  Grumph, now that I want to cut/paste, I can't get it to show the firmware 
Finally got one:
?^FGSD4e_4.0.4-P1_RPATCH.07-GS008-F-GPS-4R-1201128 01/12/2012 012

In SiRF mode, I haven't seen any data in the the block in the lower-right, 
DGPS Status.

I assume part/most of the problem is due to the lower baud rate.


Has anybody updated firmware on SiRF devices? 
(from Linux rather than Windows)


How does gpsmon decide to poll for the Firmware Version?
Is there any key I can use to get it to try again?
(Are there other packet types only polled occasionally?)

In SiRF mode, the lower left block of gpsmon says Measured Tracker, Packet 
Type 4.
The two rightmost column are labeled "?" and "SF".
What do they mean?

With a SiRF 3, I see occasionally Ts in the ? column and nothing in the SF 
With the SiRF 4, I see similar Ts and some 2 digit numbers in the SF column, 
but they get rewritten to blanks frequently and, after a delay, filled in 
again slowly.  (Seems like more than a single packet type.)

These are my opinions.  I hate spam.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]