[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: fixed bug: grep '.' didn't match some Hangul Syllables etc.

From: Paul Eggert
Subject: Re: fixed bug: grep '.' didn't match some Hangul Syllables etc.
Date: Sat, 21 May 2022 15:05:30 -0700
User-agent: Mozilla/5.0 (X11; Linux x86_64; rv:91.0) Gecko/20100101 Thunderbird/91.8.1

On 5/21/22 11:47, Jim Meyering wrote:
I've just noticed that some of those new tests fail on Fedora 35, but
probably won't have time to investigate today:

I don't see that problem on Fedora 35. I tried to reproduce it with Fedora-Workstation-Live-x86_64-35-1.2.iso running under VirtualBox, with a tarball I created from the latest 'grep'. Here's what I ran:

tar xf grep-3.7.70-c831.tar.xz
cd grep-3.7.70-c831/
make check

... and there wasn't a problem with hangul-syllable.log. The filename-lineno test failed, but that was because of a Perl module mismatch (perhaps that should be fixed in grep?) where tests/filename-lineno.log starts this way:

Can't locate File/ in @INC (you may need to install the File::Compare module) (@INC contains: . /usr/local/lib64/per5/5.34 /usr/local/share/perl5/5.34 /usr/lib64/perl5/vendor_perl /usr/share/perl5/vendor_perl /usr/lib64/perl5 /usr/share/perl5) at line 23.

I also ran the same thing on Fedora 36 x86-64 (with current patches) and RHEL 8.5 x86-64, and found no problems with the hangul-syllable test there either.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]