[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: fixed bug: grep '.' didn't match some Hangul Syllables etc.

From: Paul Eggert
Subject: Re: fixed bug: grep '.' didn't match some Hangul Syllables etc.
Date: Sat, 21 May 2022 19:02:48 -0700
User-agent: Mozilla/5.0 (X11; Linux x86_64; rv:91.0) Gecko/20100101 Thunderbird/91.8.1

Perhaps the problem is that require_en_utf8_locale_ isn't checking for proper support for Hangul Syllables in the en_US.UTF-8 locale, and that your Fedora 35 installation happens to lack that support? It'd be odd, though, as I tried both plain Fedora 35, and up-to-the-minute patched Fedora 35, and they both worked for me. Plus, Hangul Syllables have been in Unicode since Unicode 2.0 (1996) and in glibc since 2000 and I don't know why they'd be omitted from en_US.UTF-8 in this day and age.

PS. I looked into the problem with the Perl-related tests failing on Fedora when Perl is absent, and installed the attached to fix the problems I found. This is a different issue of course. (Maybe some day we should switch to Python. Oops! Time to duck and run....)

Attachment: 0001-build-be-more-careful-about-Perl.patch
Description: Text Data

Attachment: 0002-tests-port-to-platforms-lacking-Perl.patch
Description: Text Data

reply via email to

[Prev in Thread] Current Thread [Next in Thread]