[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [groff] gropdf: failed to load 'download'

From: Bernhard Fisseni
Subject: Re: [groff] gropdf: failed to load 'download'
Date: Fri, 9 Mar 2018 10:05:32 +0100

Hi Peter,

Peter Schaffter schrieb am 09.03.2018 um 03:59:
> On Thu, Mar 08, 2018, Bernhard Fisseni wrote:
>> Playing aroung with groff again, I tried to use gropdf[1] with family
>> U-P, using
>> $ groff -Tpdf -Kutf-8 -mom > Recherche.pdf
>> The family is installed in
>> `~/share/groff/1.22.3.rc1.24-ea225/font/devpdf`. However, gropdf
>> complains “Failed to open 'download'”. There is noting in
>> `~/share/groff/site-font/`.  The error message about 'download' goes
>> away if I touch `~/share/groff/site-font/devpdf/download`, but then
>> gropdf complains “Failed to open 'DESC'”, which is not so easy to fix.
>> Am I doing anything wrong?
> This seems odd, but then, you've caught us in the process of getting
> ready for the next official release of groff, so oddities are to be
> expected for the next little while.
> 'make install' usually installs everything to /usr/local/, but it
> looks like you've chosen to install in $HOME.

Yes, indeed. This has worked well for quite some time.

> I'm not sure what's happened to 'download' and 'DESC' in your
> <path to groff>/<current>/font/devpdf, which is where they normally
> live (not site-font, though you need them in site-font if you add
> your own fonts to groff).  I'm attaching versions of both files,
> generated from a fresh build.  I imagine your default papersize is
> A4, so you'll have to change the last line of DESC.

Thank you for sending the files, they set me on the right track: It
seems the problem was a local ghostscript.  Using
"--with-gs=/usr/bin/gs" works fine. Sorry for the noise!

Strangely, though I had rebuilt from scratch several times before (might
be I had only made 'clean', not 'distclean', but I remember
bootstrapping), I now get better behaviour and more specific error
messages:  Omitting "--with-gs" (and with identical `download` as
yesterday), gives:

> warning: can't find font 'U-PR'
> [mom]: Either font style "R" at line 14 does not exist in family
> "U-P",
> or family "U-P" has not been installed.

Before, the message about failing to load `download` set me on the wrong
path, especially as the files U-* did exist in the `devpdf` directory.

A question about cleaning: My groff installation directory is still
mostly `groff-1.22.3.rc1.24-ea225-dirty`, though it was clean (or
rather: lacking "-dirty") occasionally while recompiling several times
to compose this reply with the same build instructions.  I rebuilt with:

$ git reset --hard && git clean -f && make distclean
$ ./bootstrap && ./configure --with-gs=/usr/bin/gs --prefix=$HOME \
  && make -j9 install

Could building be done even less dirty?

Anyway thanks again for your help and patience,
Best regards,


reply via email to

[Prev in Thread] Current Thread [Next in Thread]