[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Problem with diskless boot

From: Rainer M Krug
Subject: Problem with diskless boot
Date: Fri, 07 Jul 2006 09:39:10 +0200
User-agent: Thunderbird (X11/20060420)


If this is the wrong newsgroup to ask, could you please direct mi to a
better one? Thanks for that.

My Problem:

I am trying to boot a diskless client (at the moment a virtual machine
in VM) via the network (DHCP server and tftp server on the host). My
system: SuSE 10.1

the tftp sever is setup and running and has the image pxegrub available.
The DHCP server is setup, assigning static IP to the VM and has the
option "option filename "pxegrub"" set. I exported the directory where
the kernel, GRUB menu config file, ... are located as read write access
for the machine VM machines. I checked, and host VM resolves to the IP.
I also tried to supply this option to this machine, but this is where
the problem comes in.
In addition, an "option T150" is defined with the tag 150 as required by
GRUB to pass the location of the  configuration file for the manu
(menu.lst). Whenever I try to boot the VM, the GRUB shell comes up and
not the menu. My guess is, I need a special way to give the path to the
GRUB menu config file. I tried

option T150 ""
option T150 "/exportedfolder/path/to/menu.lst"

but the VM only opens the GRUB shell.

I am stuck.

Do I have to compile GRUB with the network options enabled?

(with the struggle of loading the kernel, I will deal later!)

Any help welcome,


reply via email to

[Prev in Thread] Current Thread [Next in Thread]