[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Problem with diskless boot

From: Rainer M Krug
Subject: Re: Problem with diskless boot
Date: Fri, 07 Jul 2006 10:05:28 +0200
User-agent: Thunderbird (X11/20060420)

Lubomir Kundrak wrote:
> Hello!
> As manual[1] says, format of the T150 tag is "(nd)/path/to/menu.lst".
> Surely, to access (nd) device you have to have networking facilities
> compiled in.

I'll try this. Thanks.
and I have to set the T150 tag to "(nd)/path/to/menu.lst" and only
replace the path/to bit and the "(nd)" stays as it is?

> [1]
> Regards,
> Lubo
> On Fri, Jul 07, 2006 at 09:39:10AM +0200, Rainer M Krug wrote:
>> To: address@hidden
>> From: Rainer M Krug <address@hidden>
>> Date: Fri, 07 Jul 2006 09:39:10 +0200
>> Message-ID: <address@hidden>
>> Subject: Problem with diskless boot
>> Hi
>> If this is the wrong newsgroup to ask, could you please direct mi to a
>> better one? Thanks for that.
>> My Problem:
>> I am trying to boot a diskless client (at the moment a virtual machine
>> in VM) via the network (DHCP server and tftp server on the host). My
>> system: SuSE 10.1
>> the tftp sever is setup and running and has the image pxegrub available.
>> The DHCP server is setup, assigning static IP to the VM and has the
>> option "option filename "pxegrub"" set. I exported the directory where
>> the kernel, GRUB menu config file, ... are located as read write access
>> for the machine VM machines. I checked, and host VM resolves to the IP.
>> I also tried to supply this option to this machine, but this is where
>> the problem comes in.
>> In addition, an "option T150" is defined with the tag 150 as required by
>> GRUB to pass the location of the  configuration file for the manu
>> (menu.lst). Whenever I try to boot the VM, the GRUB shell comes up and
>> not the menu. My guess is, I need a special way to give the path to the
>> GRUB menu config file. I tried
>> option T150 ""
>> and
>> option T150 "/exportedfolder/path/to/menu.lst"
>> but the VM only opens the GRUB shell.
>> I am stuck.
>> Do I have to compile GRUB with the network options enabled?
>> (with the struggle of loading the kernel, I will deal later!)
>> Any help welcome,
>> Rainer
>> _______________________________________________
>> Grub-devel mailing list
>> address@hidden

reply via email to

[Prev in Thread] Current Thread [Next in Thread]