[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [PATCH/DRAFT] Support linux boot protocol >= 2.02 long command-lines

From: Vesa Jääskeläinen
Subject: Re: [PATCH/DRAFT] Support linux boot protocol >= 2.02 long command-lines
Date: Fri, 02 May 2008 21:04:59 +0300
User-agent: Thunderbird (Windows/20080421)

Alon Bar-Lev wrote:
On 5/2/08, Vesa Jääskeläinen <address@hidden> wrote:
 Hi Alon,

 Actually I meant that I have used it before in vmware desktop and it worked
fine. So I was wondering when it got broken and how did exactly you try it
out to reproduce the issue here. Because grub 2 "has to" work in vmware too

 Eg. tell that you ran this and this. And then did that.

I run:
grub-install /dev/hda

Nothing special... on boot I grub starts and goes into rescue prompt.
There is no proper documentation... So I don't know what else I can do.
I think I have a proper grub.cfg but I don't think I got to the stage
it actually can be read. As ls command command shows empty output.

I just built current CVS and tried it with my old scripts. Didn't install it to /dev/hda as cannot test it without reinstall ;)... but made core.img with modules: chain fat biosdisk. Installed it to floppy and then booted that floppy in vmware desktop 5.5.4.

Even graphics mode seem to work.

I can provide this test floppy if you want to test it out?

 I think lspci might also need some device database. So if it cannot load it
may fail. But lets first tackle this vmware problem :)

But this is basic... the module is loaded... I understand that the
disk may not be detected, but I expect command to be available.

insmod pci
insmod lspci

reply via email to

[Prev in Thread] Current Thread [Next in Thread]