[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Grub2 svn2059

From: BandiPat
Subject: Re: Grub2 svn2059
Date: Sun, 05 Apr 2009 23:27:30 -0400
User-agent: Thunderbird (X11/20090302)

Andreas Born wrote:
BandiPat schrieb:
Thanks Andreas, I just figured that out as well when testing on another machine just now. If you still have the file I sent you for svn2059, would you mind testing it on your machine as well. I'm tempted to send you the svn2059 or 2065 to compile on your current machine, to see if it behaves differently than the one I built. Be prepared though, as I'm sure you'll need to re-install svn2031 back after 2059 fails to boot. Keep your LiveCD available to reboot! :-)
I tested the svn2059-60.1 build on my current Zenwalk installation. It would boot here, but I have it installed to superblock of my ext3 partition, so that might be the difference. Therefore I installed grub2 to the MBR, but like that it would work too.
But I noticed two other problems:

   * If I drop to console with 'c' from the menu and then reload the
     menu with 'configfile (hd0,3)/boot/grub/grub.cfg', 'prefix' is
     unset and I can't boot. If I drop then back to console I can set
     'prefix' properly to '(hd0,3)/boot/grub' and boot from console,
     but configfile won't work.
   * With the 'linux' loader as opposed to the 'linux16' loader, I
     would always get a verbose splash, although I force a silent one
     with 'splash=silent'. My assumption was that the kernel parameters
     are ignored at all, but passing a wrong root resulted in a error.
     So either only 'splash=silent' is ignored or its something
     completely different. I think the problem is related to the one
     described in "New linux loader doesn't like vga=1".

Ok, I'm not sure I understand what all of this means, except the part that you mentioned it worked for you. That at least tells me the build is not bad. Since I don't presently have a current 6.0 setup, I can't test that right now, but will do a new install so I can.

I've never installed to the superblock, just the mbr, but I'll assume that's not the problem, since you seem to have gotten both to work. As I mentioned, I have tried this on two snapshot systems, where both have failed using 2059 or above. Since you haven't tried it on your snapshot, and this file will work there as well because the only difference is I compiled one as 686 the other 486. I would be interested to know your results there as well.

I've got an idea I'm going to try, but not sure it will make a difference. Thus far, I've been using the previous grub.cfg created by 2031, so I think I'll try to let 2059 create a new one. Again not sure it would make a difference because it appears the loader is not getting to the grub.cfg before it fails.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]