[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Require at least gcc 4.2

From: Neil Cafferkey
Subject: Re: Require at least gcc 4.2
Date: Sun, 6 Sep 2009 16:03:28 +0100
User-agent: Mutt/

On Thu, Sep 03, 2009 at 04:21:55PM +0200, Robert Millan wrote:
> On Tue, Sep 01, 2009 at 03:23:01PM -0700, David Miller wrote:
> > From: "Vladimir 'phcoder' Serbinenko" <address@hidden>
> > Date: Tue, 1 Sep 2009 16:12:20 +0200
> > 
> > > Even if gcc<4.2 seem to work ok I think we shouldn't waste resources
> > > on it and officially declare a minimal requirement ("you're free to go
> > > under requirement but don't post bugreports if you do")
> > 
> > You're making it such that I won't be able to do development on my
> > main sparc development machine, which is using gcc-4.1.3
> > 
> > In my view, this is going a bit overboard as a method to address this
> > problem.
> Why not just skip the check?  (e.g. --disable-gcc-check)

The central issue IMO isn't whether this is enforced by configure, but
whether it's legitimate to report failure to build with older compilers
as a bug.

No offence, but this proposal strikes me as slightly lazy. In other words,
I think these bugs should be identified instead of being "fixed" by
declaring "your compiler is too old".

FWIW, I still use i386-elf-gcc 3.4.3 under Mac OS X, because (last time I
checked) it's the most recent version available from macports. The fact is
that a lot of people outside those who install a new version of Linux
every six months or so are still using these old compilers.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]