[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: grub-install for FreeBSD

From: Felix Zielcke
Subject: Re: grub-install for FreeBSD
Date: Thu, 24 Sep 2009 20:12:06 +0200

Am Donnerstag, den 24.09.2009, 11:01 -0700 schrieb Brian R. Jones:
> Robert Millan wrote:
> > On Wed, Sep 23, 2009 at 08:36:01AM +0200, Vladimir 'phcoder' Serbinenko 
> > wrote:
> >> Andrey Shuvikov wrote:
> >>> Hello,
> >>>
> >>> I tried to install Grub2 under FreeBSD but grub-install failed because 
> >>> readlink doesn't understand -f and stat doesn't have -c. I edited 
> >>> to use different commands instead. I'm not sure it's 
> >>> the right way to handle this difference but it worked. The patch is 
> >>> attached.
> >>>
> >>>   
> >> We're aware of this problem. Felix Zielcke has a solution but at this
> >> point it's deemed too intrusive. We'll probably commit it once feature
> >> freeze is over
> > 
> > Alternatively, I could also allow a patch that checks the capabilities of
> > those commands.  It should try readlink first, and fallback to greadlink
> > if necessary.
> > 
> Not sure if Felix's patch covers it, but there is also a problem with the 
> 'sed' syntax in 10_freebsd and 30_os-prober.  It turns out that freebsd 
> 'sed' is quite retarded (at least in 7.2) and doesn't know that '\t' is 
> supposed to be tab.  Replacing 'sed' with 'gsed' or 'perl -p' fixes this 
> issue.

No it doestn't.
Autoconf has an AC_PROG_SED macro which checks for a POSIX sed.
Portable sed regular expressions should use ‘\’ only to escape
characters in the string ‘$()*.0123456789[\^n{}’

If I understand that right, POSIX doestn't mandate \t so it wouldn't
help us.

> Where would I go to view Felix's path?  I am concerned because freebsd also 
> has a 'gstat' command that does not work either.  Only by installing the 
> coreutils and pointing explicitly at the coreutils version of gstat did I 
> get this to work.

Felix Zielcke
Proud Debian Maintainer

reply via email to

[Prev in Thread] Current Thread [Next in Thread]