[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [PATCH v3 02/10] luks2: Improve readability in luks2_get_keyslot.

From: Daniel Kiper
Subject: Re: [PATCH v3 02/10] luks2: Improve readability in luks2_get_keyslot.
Date: Fri, 23 Oct 2020 14:14:52 +0200
User-agent: NeoMutt/20170113 (1.7.2)

On Mon, Oct 19, 2020 at 06:09:50PM -0500, Glenn Washburn wrote:
> Introduce new variables keyslot_key, digest_key, and segment_key which
> represent the integer key of the item in the respective associative array
> when looping over the array items. This replaces using a generically
> named variable named "idx" used for all three values. The parameter "i"
> is renamed to "keyslot_idx" and the loop variable "j" is renamed to "i".
> Error messages now distinguish between indexes and keys.  The former
> include "index" in the error string, and the later are surrounded in quotes.

I think this patch does too many things in one step. Please do one
rename per patch if possible. Additionally, I think this patch, or
series of the patches, should be before current patch #1.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]