[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Cleanup mark-during-GC debug checks.

From: Ludovic Courtès
Subject: Re: Cleanup mark-during-GC debug checks.
Date: Wed, 10 Sep 2008 09:36:40 +0200
User-agent: Gnus/5.11 (Gnus v5.11) Emacs/22.3 (gnu/linux)


Han-Wen Nienhuys <address@hidden> writes:

> Ludovic Courtès escreveu:

>>   1. I don't want to use a web interface to review code.  Most free
>>      software projects use email in one form or another, which I find
>>      convenient.  Having patches in-lined is optimal IMO.
> My experience is that a web interface (which tracks different versions of 
> the same patch) is a lot easier when it is a major change with lots of 
> revisions.   

It's really a matter of taste.  I prefer email and/or topic branch in

>>   * I'd name the macro `SCM_DEBUG_MARK_PHASE' rather, as it sounds mot
>>     idiomatic (but I'm not a native speaker).
> It's rather the reverse: ensuring that the non-mark phase is correct (in
> not having mark calls), but I couldn't think of a good name.

My comment was about "marking phase" vs. "mark phase".

>>   * Use "static const char msg[] = ...".
> done.

OK, feel free to push!

Hope we'll keep compiling with `SCM_DEBUG_MARK_PHASE == 1'!  :-)


reply via email to

[Prev in Thread] Current Thread [Next in Thread]