[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Kisê 0.9.3 released

From: David Pirotte
Subject: Re: Kisê 0.9.3 released
Date: Mon, 21 Jan 2013 15:48:51 -0200

Hello Sajit,

        please allow me to re-route this conversation to guile-user and
        guile-gtk-general, since the problem you are facing is a lack of an
        up-to-date set of packages for the latest guile-gnome-platform version 
        debian [see my explanation in the previous mail and here below]. i am 
        saying it is a guile-gnome-platform developer/maintainer problem, it is 
        but it helps raising the question of packages on debian [and other

Le Mon, 21 Jan 2013 01:40:50 -0500,
Sajith T S <address@hidden> a écrit :

> Hello David,
> David Pirotte <address@hidden> wrote:
> > > What would be the dependencies on a Debian system? 
> > 
> > dependencies are listed here:  
> > please
> > double check guile's version and guile-gnome's version you have: it will 
> > not work
> > with guile-gnome 2.16.1-4 [the latest debian package if i am not mistaking]
> On Debian there's guile-gnome2-gnome and guile-gnome2-gnome-ui.  I
> have installed both, but I guess it would be useful to know exactly
> which package to install.

Yes, unfortunately, as I said in my previous answer, and as it is stated on the
'Quickstart' section of Kisê's download web-page, it will _not_ run with
guile-gnome-platform prior to 2.16.2. Unfortunately, it is also very unlikely 
guile-gnome-platform will get to this version on debian, see:

So, you'll have to install the latest from the tarball: it is not that 
difficult and
I am sure some guilers, including myself of course can help you:

If you wish, for that matter, I regularly appear on freenode, channel #guile 

> > >     $ ./kise 
> > >     ERROR: no code for module (system locale)
> > 
> > it seems you forgot one of the steps described on the download page as well:
> > 
> >     export GUILE_LOAD_PATH=/opt/nongnu:/opt/nongnu/common
> > 
> >     [ assuming you installed in /opt/nongnu of course ...]
> Did exactly that, and now there's this new error:
>     $ ./kise 
>     ERROR: Unbound variable: eval-when

Yes, this is because ./kise actually runs guile-gnome-2, and the version you are
running [from the debian packages] actually runs guile-1.8:

         Kisê requires guile >= 2.0.5

> > there are 3 screenshots on ( 
> > once you
> > are on this page, click on the numbers that appear below the menu items 
> >
> > load the shots... )
> Ah, I see!  That didn't look so obvious to me.  (And the images look
> stretched on a 1920x1080 monitor, when the browser is expanded.)
> Maybe the page deserves a redesign?

I don't know, maybe :)


reply via email to

[Prev in Thread] Current Thread [Next in Thread]