[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [PATCH 1/4] lint: Add packages with suffix ':bin' to 'inputs-should-

From: Tobias Geerinckx-Rice
Subject: Re: [PATCH 1/4] lint: Add packages with suffix ':bin' to 'inputs-should-be-native'.
Date: Thu, 21 Jul 2016 21:27:49 +0200
User-agent: Roundcube Webmail/1.1.2

Ahoy Ludo',

On 2016-07-21 18:06, address@hidden wrote:
  (inputs `(("somethingsilly" ,glib "bin")))

This "somethingsilly" is just a label that allows you to refer to an
input on the build side, in idioms like:

  (assoc-ref inputs "somethingsilly")
  => "/gnu/store/…-glib-42.0-bin"

I remember writing something like

  (inputs `(("libuuid" ,util-linux)))

once, to indicate that libuuid really is all we need and that one
could swap out util-linux for another — extremely hypothetical —
libuuid provider.

Was this, in hindsight, somethingsilly? :-)

If so, is there still a reason to keep all this duplication around?

This predates g-expressions, which solve this problem more elegantly.

Interesting! I always assumed[1] gexps were one of the foundations for
Guix since day 0.

Kind regards,


[1]: Don't.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]