[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [PATCH 05/20] gnu: Add python-sphinx-1.3.3

From: Hartmut Goebel
Subject: Re: [PATCH 05/20] gnu: Add python-sphinx-1.3.3
Date: Sat, 15 Apr 2017 19:38:57 +0200
User-agent: Mozilla/5.0 (X11; Linux x86_64; rv:45.0) Gecko/20100101 Thunderbird/45.8.0

Am 15.04.2017 um 19:28 schrieb Hartmut Goebel:
> Am 14.04.2017 um 12:13 schrieb Muriithi Frederick Muriuki:
>>  (define-public python2-sphinx-rtd-theme-0.1.9
>>    (package-with-python2 python-sphinx-rtd-theme-0.1.9))
>> +
>> +(define-public python-sphinx-1.3.3
>> +  ;; python-httpretty has a hard requirement for
>> +  ;; sphinx == 1.3.3
> Please test if it works with an up-to-date version of sphinx, too. There
> are very few reasons for requiring strict version of a tool like sphinx
> or sphinx-rtd-them. And we should avoid adding versions over versions of
> packages.

# HTTPretty doesn't have any requirements per se so far. yay!

So I assume you take the version definitions in "development.txt" as
"hard requirement" - but this file only defines *one* valid set of
dependencies. So please review *all* the packages you say
"python-httpretty has a hard requirement" and try to get rid of them. It
may be even better to patch or "substitute" httpretty to make it work
with our set of versions instead of piling of version of packages used
only for this one. Thanks.

Schönen Gruß
Hartmut Goebel
Dipl.-Informatiker (univ), CISSP, CSSLP, ISO 27001 Lead Implementer
Information Security Management, Security Governance, Secure Software

Goebel Consult, Landshut


reply via email to

[Prev in Thread] Current Thread [Next in Thread]