[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [PATCH 05/20] gnu: Add python-sphinx-1.3.3

From: Leo Famulari
Subject: Re: [PATCH 05/20] gnu: Add python-sphinx-1.3.3
Date: Mon, 17 Apr 2017 15:15:03 -0400
User-agent: Mutt/1.8.1 (2017-04-11)

On Sat, Apr 15, 2017 at 07:38:57PM +0200, Hartmut Goebel wrote:
> Am 15.04.2017 um 19:28 schrieb Hartmut Goebel:
> > Am 14.04.2017 um 12:13 schrieb Muriithi Frederick Muriuki:
> >>  (define-public python2-sphinx-rtd-theme-0.1.9
> >>    (package-with-python2 python-sphinx-rtd-theme-0.1.9))
> >> +
> >> +(define-public python-sphinx-1.3.3
> >> +  ;; python-httpretty has a hard requirement for
> >> +  ;; sphinx == 1.3.3
> > Please test if it works with an up-to-date version of sphinx, too. There
> > are very few reasons for requiring strict version of a tool like sphinx
> > or sphinx-rtd-them. And we should avoid adding versions over versions of
> > packages.
> says:
> # HTTPretty doesn't have any requirements per se so far. yay!
> So I assume you take the version definitions in "development.txt" as
> "hard requirement" - but this file only defines *one* valid set of
> dependencies. So please review *all* the packages you say
> "python-httpretty has a hard requirement" and try to get rid of them. It
> may be even better to patch or "substitute" httpretty to make it work
> with our set of versions instead of piling of version of packages used
> only for this one. Thanks.

I agree, it would be best if we could avoid collecting many versions of
packages like Sphinx; it will become a pain to maintain them later.

On the other hand, it is also a burden to maintain patches against
upstream code. Both approaches cost human time and energy.

Personally, I think it's up to Frederick how he decides to handle this,
since he will be maintaining these packages in the future :)

Attachment: signature.asc
Description: PGP signature

reply via email to

[Prev in Thread] Current Thread [Next in Thread]