[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [PATCH][WIP] Elogind update

From: Stefan Stefanović
Subject: Re: [PATCH][WIP] Elogind update
Date: Tue, 13 Nov 2018 12:37:32 +0100

Status update:
The solution Andy provided works.
The PID file has a new path:
Additional patch that is needed,
will be provided with this message.

All that remains is to figure out how
to integrate this update to Guix,
following the next release of elogind (v239.2).

Any advice and suggestion is appreciated,
since I am relatively new to Scheme and Guix.

Replacing elogind package definition in place
did not work for me the last time I tried it.
Problem is the guix commands were stuck/busy
(not stuck building or anything like that,
just stuck like "in an infinite loop")
every time I tried to build elogind,
with the newer package definition
as replacement for the older one.

Maybe I should have tried
and waited for a few hours.

The only thing that avoided this issue was
the replacement of "elogind" with "elogind-next"
while leaving the older elogind package intact.
It might be the case that my guix environment
setup is wrong. Am I missing something obvious?

Any comment around described
issue is appreciated.
Thank you.


Attachment: 0001-gnu-elogind-next-Change-PID-file-path.patch
Description: Text Data

reply via email to

[Prev in Thread] Current Thread [Next in Thread]