[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: ‘staging’ and GNOME updates

From: Ludovic Courtès
Subject: Re: ‘staging’ and GNOME updates
Date: Tue, 16 Apr 2019 22:14:31 +0200
User-agent: Gnus/5.13 (Gnus v5.13) Emacs/26.2 (gnu/linux)


Timothy Sample <address@hidden> skribis:

> Ricardo Wurmus <address@hidden> writes:
>> Ludovic Courtès <address@hidden> writes:
>>> I removed pretty both .cache directories, moved .config sub-directories
>>> around, etc., and yet I am still unable to log in into the GNOME account
>>> (logging in to a non-GNOME account from GDM is fine.)
>>> I even tried upgrading the user’s profile just in case is contained
>>> incompatible schemas or who knows what, but that didn’t help.
>>> What extra bit of state am I missing?
>> Do you have ~/.local?  In my earlier tests this contained binary
>> notification data that when loaded would lead to a crash.
> I’m testing GNOME on ‘staging’ now, and had the same problem (GDM worked
> okay, but I could not login).  I fixed it by deleting
> “~/.local/share/gnome-shell/notifications”.  I left everything else in
> my home directory as it was.

That’s the one!  I moved ~/.local/share/gnome-shell out of the way and
after that I could log in.  \o/

~/.local/share/gnome-shell contained a single file, “application_state”.
It’s an XML file that looks exactly like the one created by the newer
GNOME: same schema, same attributes, etc.

The weird thing: if after successfully logging in, I log out, move the
old ~/.local/share/gnome-shell into place, and log in again, it works.

Perhaps the mere presence of ~/.local/share/gnome-shell causes it to
take a different path?


Thank you!


reply via email to

[Prev in Thread] Current Thread [Next in Thread]