[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: SELinux log

From: Laura Lazzati
Subject: Re: SELinux log
Date: Sun, 9 Jun 2019 23:08:45 -0300


More info after having my fresh install.

First, I ran semode, and checked with -Z option my /gnu dir successfully. After that, I created the file and rebooted. While rebooting this time I got the message telling me that the system was being relabeled. Then, I ran restorecon and set SELinux to Permissive mode. Tried it doing a guix search hello.

My audit log showed:

type=AVC msg=audit(1560131803.485:381): avc:  denied  { search } for  pid=8177 comm="bash" name="guix" dev="dm-0" ino=679365 scontext=unconfined_u:unconfined_r:unconfined_t:s0-s0:c0.c1023 tcontext=unconfined_u:object_r:guix_daemon.guix_daemon_conf_t:s0 tclass=dir permissive=0

After that I SELinux to Enforcing to see what message I got i the CLI, and it was a Permission Denied, and now I am getting that guix is not installed, double checking with  `which guix` :S

I am trying installing guix again with the script, and it reaches the point where I get:
mv: cannot stat '/var/guix': Permission denied

Any ideas?


reply via email to

[Prev in Thread] Current Thread [Next in Thread]