[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Installer script on Fedora doesn't work properly

From: Jan Wielkiewicz
Subject: Installer script on Fedora doesn't work properly
Date: Tue, 30 Jun 2020 00:04:53 +0200


I'm trying to install Guix on Fedora using the install script, but
something is not right.
I ran the script as root, it installed everything properly, but running
"guix pull" ends up with an error message: "guix pull: failed to connect
to `/var/guix/daemon-socket/socket': No such file or directory".
I tried rebooting a few times, running "systemctl enable guix-daemon",
"systemctl start guix-daemon", but with the same result.
Any idea what's wrong?
I think the installer script should *just work at all times* - this is
crucial to make Guix popular on other distros.
My suggestion: if it's not already done, consider adding automated
tests, checking whether the installer script works on major
distributions (on a VM) and if Guix works there. This should be checked
every release.

P.S. I'm going to resume my work on Jami soon, I've been busy with my
exams lately :P

Jan Wielkiewicz

reply via email to

[Prev in Thread] Current Thread [Next in Thread]