[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: mounting a directory in a system container

From: Efraim Flashner
Subject: Re: mounting a directory in a system container
Date: Thu, 3 Sep 2020 14:44:01 +0300

On Thu, Sep 03, 2020 at 02:35:10PM +0300, Efraim Flashner wrote:
> I really like the --expose and --share options from guix system vm but I
> really would prefer to use a system container (mostly for the shared
> resources). I tried adding the directory in the file-systems section of
> my OS-config but it just failed to mount. Any suggestions?
> (file-systems (cons
>                (file-system
>                 (device "/data")
>                 (mount-point "/data")
>                 (type "none")
>                 (flags '(read-only bind-mount))
>                 (check? #f)
>                 (create-mount-point? #t))
>                %base-file-systems)
> I also added (service udev-service-type) to my services.

Thanks everyone for being my rubber ducky! On a whim I checked the
manual and it mentioned --share and --expose for containers also and it
worked for me. It would appear that the 'guix system --help' text isn't

Efraim Flashner   <>   אפרים פלשנר
GPG key = A28B F40C 3E55 1372 662D  14F7 41AA E7DC CA3D 8351
Confidentiality cannot be guaranteed on emails sent or received unencrypted

Attachment: signature.asc
Description: PGP signature

reply via email to

[Prev in Thread] Current Thread [Next in Thread]