[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

core-updates-frozen on powerpc64le-linux (was: Core updates frozen.)

From: Thiago Jung Bauermann
Subject: core-updates-frozen on powerpc64le-linux (was: Core updates frozen.)
Date: Tue, 03 Aug 2021 17:15:11 -0300


Em quarta-feira, 28 de julho de 2021, às 08:50:16 -03, Mathieu Othacehe 
> Hello,
> A new core-updates-frozen branch is available here:


> This means that the core-updates branch remains open, while the
> core-updates-frozen branch will only accept bug fixes.
> This branch contains exciting new features, such as:
> * Switch to GCC 10.
> * Update to TexLive 2021.
> * Simplified package inputs[1].
> * Build system Gexp support[2].
> * Meson cross-compilation support[3].
> between lots of other things.

Really nice refresh indeed.

> Cuirass has started evaluating this branch here:
> According to the
> related dashboard, there's still a bit of work required to stabilize
> this branch:

There are no results for powerpc64le-linux. Does anyone know why?

> Your help is welcome :).

A few days ago I requested access to a VM on the Unicamp/IBM Minicloud, and 
had it granted a couple of hours later so now now I have a POWER VM to play 
with. :-)  I was a bit surprised to see it’s actually a POWER8 system 
rather than POWER9, but I don’t think it matters for Guix development and 

I’m using a guest with 8 vCPUs and Debian testing installed. Guix is 
working fine on it, installed from Debian’s experimental ‘guix’ package 
(thanks vagrant!) and then updated from v1.3 to master with `guix pull`. 
The Minicloud allows use for 30 days, and can extend it to 30 more days. 
Hopefuly, that should be enough to help get core-updates in shape on 

The last Cuirass evaluation of core-updates with powerpc64le-linux results 
is so I tried to run the failed builds 
on my VM to see what the current state is. My core-updates-frozen branch 
was at commit f8458a228224 (”build-system/python: Handle missing metadata 
on Python 2.”) when I did these builds.

At first, I didn’t try the “*tarball*” builds because I didn’t want to 
focus on the bootstrap binaries. Apart from those, I was glad to see that 
all failed powerpc64le-linux builds from that evaluation built fine on my 
VM, except for the ones below:

• gcc-toolchain@4.8
• gcc-toolchain@5.5
• gmp@4.3.2 aka `(@@ (gnu packages commencement) gmp-boot)`
• mpfr@2.4.2 aka `(@@ (gnu packages commencement) mpfr-boot)`
• mpc@1.0.3 aka `(@@ (gnu packages commencement) mpc-boot)`

I later tried building ‘bootstrap-tarballs’, but it failed during the build 
of the static gawk binary.

I also did a `guix pull --branch=core-updates-frozen`, which built a ton of 
stuff and completed successfully. At the time, core-updates-frozen was at 
commit 5e4cdb5b3b1d (”gnu: python-django: Fix test failure.”)

So next step for me is to look into the build failures above. I’ll semi-
randomly start with ‘gmp-boot’ and see what I can find out.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]