[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Freeing Machine Learning with ROCm

From: Lars-Dominik Braun
Subject: Re: Freeing Machine Learning with ROCm
Date: Tue, 26 Apr 2022 08:24:38 +0200

Hi Zacchaeus,

> I tried kernel version 5.15 before I tried 5.4.  Is there anything else
> special about your kernel version?
no, pretty much the stock Gentoo kernel.

> [   12.523127] [drm:sdma_v4_0_early_init.cold [amdgpu]] *ERROR* sdma_v4_0:
> Failed to load firmware "/*(DEBLOBBED)*/"
> [   12.523277] [drm:sdma_v4_0_early_init.cold [amdgpu]] *ERROR* Failed to
> load sdma firmware!
Yeah, you definitely need firmware. Even my pretty old RX 460 needs
it to do 3D accelleration and OpenCL/Vulkan.

> That "Fatal error
> during GPU init" is pretty discouraging though...  With the way AMD
> promoted ROCm as being so open, I was really under the impression that I
> would be able to make this work on Guix, albeit with some work on my end,
> but you sound skeptical.  Do you think it is possible?
Sure, it might work if you use a nonguix[1] kernel plus firmware – unless
your GPU needs a newer ROCm. In that case we have to figure out how to
upgrade ROCm itself, which is always a little tricky.



reply via email to

[Prev in Thread] Current Thread [Next in Thread]