[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Guile code snippet

From: Ricardo Wurmus
Subject: Re: Guile code snippet
Date: Thu, 21 Apr 2022 22:46:20 +0200
User-agent: mu4e 1.6.10; emacs 28.0.50

Olivier Dion <> writes:

> On Thu, 21 Apr 2022, Ricardo Wurmus <> wrote:
>>>> This is now fixed with commit
>>>> dceec9ecb9e24252ab9130f7a3626c00b2ff1a68.
> I tried this:
> process foo
>   packages "guile" "guile-fibers"
>   # /bin/guile {
>     (use-modules (fibers))
>   }

You’re missing “-c”.  If you just use /bin/guile it expects a file name,
just like it does on the command line.  This works fine:

process run
  packages "guile" "guile-fibers"
  # /bin/guile -c {
    (use-modules (fibers))

> Also tried this:
> process foo
>   packages "guile" "guile-fibers"
>   procedure
>     . `(begin
>         (use-modules (fibers)))

I haven’t addressed this yet.

What happens here is that we are in fact setting GUILE_LOAD_PATH and
GUILE_LOAD_COMPILED_PATH (as we do for any search path specification
associated with the list of packages), but that has no impact on the
load path of the Guile process used to evaluate the expression.

I’ll investigate this.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]