[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Errors when building from source

From: Akim Demaille
Subject: Re: Errors when building from source
Date: Wed, 26 Dec 2018 18:25:55 +0100

Hi Wouter,

> Le 26 déc. 2018 à 15:57, Wouter Beek <address@hidden> a écrit :
> Dear Bison users,
> I'm having trouble building recent Bison versions from source.  (I
> want to use a fairly recent Bison version because of the recent
> improvements for C++.)  Does anybody else encounter these problems as
> well, or am I making a mistake.
> These are the commands that I run:
>    git clone
>    cd bison
>    git submodule update --init
>    ./bootstrap
>    ./configure
>    make
> When I do this with the current master HEAD (commit a4ed...):
>    src/scan-code-c.c:3:10: fatal error: src/scan-code.c: No such file
> or directory
>     #include "src/scan-code.c"

I ran the same sequence, and it worked as expected.  I would need more 
information, such as more the complete logs of "make".  You do have flex, right?

> When do this on a checkout of tag v3.2.4:
>    In file included from src/AnnotationList.c:23:0:
>    src/AnnotationList.h:23:11: fatal error: bitsetv.h: No such file
> or directory
>     # include <bitsetv.h>

master and 3.2 have different versions of gnulib, you need to bootstrap again.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]