[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [help-GIFT] Getting GIFT from Savannah

From: David Squire
Subject: Re: [help-GIFT] Getting GIFT from Savannah
Date: Fri, 02 Apr 2004 13:18:06 +1000
User-agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5) Gecko/20031007

David Squire wrote:

Wolfgang Müller wrote:

On Sunday 21 March 2004 23:44, David Squire wrote:
Hi folks,

I am trying to download the latest GIFT from Savannah. I haven't done
this for quite a while, and it seems not to be working. Following the

instructions on the web page, I do:
>set CVS_RSH="ssh"
>cvs -z3 -d:ext:address@hidden:/cvsroot/gift co gift

It just hangs. No prompt. Nothing written to the directory. When I hit
^C, I get:


Hi, David,

Thanks for giving it a try.

I tried it after the FSF security problems (these were fixed in december 2003, so I tried somewhere in january 2004). The thing to make sure when getting things from CVS is to make sure that you're using version 2 of the SSH protocol. This can be done by an entry in ssh_config.
Hi Wolfgang,

No luck, I'm afraid.

My ~/.ssh/config now contains the line:

Protocol 2,1

But this seems not to have helped. I now have:

>set CVS_RSH="ssh"
>cvs -t -z3 -d:ext:address@hidden:/cvsroot/gift co gift
-> main loop with CVSROOT=:ext:address@hidden:/cvsroot/gift
-> Starting server: rsh -l anoncvs cvs server
cvs [checkout aborted]: received interrupt signal
-> Lock_Cleanup()

Again, it just hangs. I wonder if this has something to do with a proxy? Do you know what port this uses?

Though looking at this again, it is the 'set CVS_RSH="ssh"' which has not worked - it's still invoking rsh. Something weird going on with environment variables at my end...



Dr. David McG. Squire, Postgraduate Research Coordinator (Caulfield),
Computer Science and Software Engineering, Monash University, Australia
Monash Provider No. 00008C

reply via email to

[Prev in Thread] Current Thread [Next in Thread]