[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Using global with libraries

From: Joseph Garvin
Subject: Using global with libraries
Date: Tue, 24 Mar 2009 15:05:22 -0400

Global works great for my own .cpp files, but I can't get it to work
with libraries to save my life.

~/tmp$ gtags /usr/include/qt4
gtags: cannot make GTAGS.

Hrm, I thought the whole point of running the command from my home
folder is that it wouldn't need permissions because it'd be saving
here. Maybe if I give it a file list like in the examples...

~/tmp$ find /usr/include/qt4 -name d -o -name f \*.h > tmpfiles
~/tmp$ gtags -f tmpfiles
Warning: ... is out of source tree
Warning: ... is out of source tree
Warning: ... is out of source tree
Warning: ... is out of source tree

And it still doesn't generate any tags! Doesn't give any errors
either, that's sort of misleading. Hrm, lets dig into the docs some
more.. ah hah! What I need to do is set GTAGSLIBPATH. Lets try that...

~/tmp$ GTAGSLIBPATH=/usr/include/qt4 gtags

Ah hah! It completed silently, everything must be working... except it
doesn't. It just generated tags for my local files again.

At that point I gave up. In all honesty, although global is great when
it works, has anyone considered the documentation work that could be
saved if things just worked intuitively? Or if it at least gave error
messages when it didn't work? Maybe there's some rationale for it
working this way, but I'm inclined to say the fact that the first
example doesn't work (index specified folder and add collected tags to
GTAGS file in current folder) is a bug.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]