help-glpk
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Help-glpk] Suggestions for improvements


From: Shripad Thite
Subject: [Help-glpk] Suggestions for improvements
Date: Mon, 26 Jul 2004 11:12:26 -0500

Hi,

Forgive me for possibly repeating previously discussed issues on this
mailing list.  I have seen at least one reference to the first problem
(as I think of it) with GLPK.

I think it would be great if the following changes were made to GLPK
in a future version:

1)  I strongly believe that the array indexing should be changed to
start with an index of zero instead of one as is the convention
currently.  Since GLPK provides an API interface to C and C++ programs
which begin arrays at index 0, it is cumbersome to allocate an array
with one extra space and adjust all indices by one to make a program
work correctly with GLPK.

2)  Currently, constant values like return values (LPX_E_OK, etc.) and
parameters (LPX_MIN, LPX_LO, etc.) are processed by the pre-processor.
 As a result, the compiler only sees the numeric value and not the
symbolic name.  So, for instance, an assertion failure quits with the
message
  "Assertion `glp_lpx_simplex( lp ) == 200' failed."
If the definitions of these constants were changed so that the
compiler sees the symbolic names, then the error messages would be
much more readable and useful.  For instance, in my program I do:
#undef LPX_E_OK
const int LPX_E_OK = 200;
after which I get the much better error message:
  "Assertion `glp_lpx_simplex( lp ) == LPX_E_OK' failed."

(The reason the assertion fails in my program is a topic for the bug
mailing list. :))

I look forward to responses from the GLPK developers and users.

Thanks,
Shripad




reply via email to

[Prev in Thread] Current Thread [Next in Thread]