[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

RE: GNATSWEB installation

From: Uma R
Subject: RE: GNATSWEB installation
Date: Mon, 16 Jul 2001 18:29:33 -0700

   I have started doing the installation as per what Ramesh has sent me in
email but i am still facing problems in installation.

1. when i run the setup utility as a 'root' the configurations were not
changing even if I tried changing them. The default firewall
setting was high. I now want to change it.

2. Also when I tried doing send-pr it says it can't find the categories file
in /usr/local/share/localhost and I am not able to use send-pr

3. Created a file called gnats-db.conf in /etc and added the line u
mentioned in that

4. Tried running the test but it said the same error

 Content-type: text/html

 <H1>Software error:</H1>
 <CODE>Can't call method &quot;header&quot; on an undefined value at line 2198.
 For help, please send mail to this site's webmaster, giving this
 error message
 and the time and date of the error.

 [Wed Jul 11 20:05:59 2001] Can't call method "header" on an
 undefined value at line 2198.
 make: *** [test] Error 111

Now I am again stuck up with the installation things. Could u pls help me in
that. Can u gimme the contact details of anyone (urs too)
so that i can call them and clear the doubts. This emailing takes days in
communication. I want to it be done soon and its really a
critical one too.

Thanks in advance

-----Original Message-----
From: S Ramesh [mailto:address@hidden
Sent: Friday, July 13, 2001 10:54 PM
To: Uma R
Subject: Re: GNATSWEB installation

If u r installing in redhat 7.1 vcersion or more.. checkout the
firewall configuration. login as root and run the setup command and
chk out the firewall configuration. if it is high.change  it
according to ur need like medium or no. coz if its high means surely
it wont allow anny connections from outside. so comes the error...

connection failed or connection  refused. thsi will surely work.

the problem with solaris i dont know.. i think a version of gnats is
there specially for solaris.

check out this page. there a link is provided for solaris. I haven't
tried that. why don't u.

Regadring TKgnats.. it works fine when the shell utilities like
send-pr and edit-pr works fine.

Instead of going for Tkgnats why can't  u use the webinterface.
Do the following steps to install the webinterface in linux 7.2

1. Get the Gnatsweb 2.8.2
2. then chk the firewall config.. for checking purpopse.. make it as
no firewall.
3. Now perl and all will be there in 7.2 version so no need to make
any changes in the file.
4. Before these steps u need to have atleast one problem report int
he gnats-db. what i mean in u will have some 4 categories whcih
already will be there know like gcc, doc, test .,.. atleast one of
these directories should have a problem report. if u dont have

go to command propt and


here u give the category as test. and send the report. when the cron
deamon find this report in the gnats-queue directory it will use
file-pr to file it with a number inthe correspding category
directory.. in our case.. its test. so test will be having the PR. if
this step itself is not working means.. u have to check the archive
where Margret ( retreiver company ) has sent a mail to me.. regd how
to make work queue-pr ( read this if needed ).

5. Now u have a problem report under directory test. create a file in
/etc directoy like

this file should contains the database alias name
type as


(fi u installed as per the instruction then this direcorty will be
there for u in ur macine )

then edit ur gantsd.conf

type as *:*:edit:dbase

(this is a test configuration so that anybody can access the database
with edit permission... also note that that dbase is my alias --i.e
my chossen alias name. u can have ur own ).

simillarly in the gnatsd.access file edit like

use some alid usernames and passwds with permission



6. thats all config stuff is over. now its only testing..

make test USERNAME=gnats PASSWORD=gnats DATABASE=dbase

surely this will say all test succedded.. if u done the stpes what i
mentioned correctly.

7. then install like

make install CGI_DIR=/var/www/cgi-bin

exactly type this command  as root. surely this wont create any probs.
if u have doubt on my words.. chk out whether a directory like
/var/www/cgi-bin is there if so what i have said is coorect. if not
then ur apache isn ot installed properly.

8. Thats it steps are over..


u will be asked for username and passswd.. eeverything is over.. if
ur server ip address is local. then make sure that this IP should be
bypassed by the proxy like that of ur intranet server ( if u r doing
in a intranet ).

Hope this stuff will really make u install gnatsweb.. ihad stuck up
in the lot of steps mentioned. Margret hashelped me a lot and also
the Gnatsweb Maintener. but still i have some config problem and
expecting people to help me.. even u also. if u have any problem in
the steps mentioned.. contact me...



On Saturday 14 July 2001 02:36 am, Uma R wrote:
> We have installed Linux (Redhat) version 7.2. Also in solaris we
> face the same problem.
> Do anyone have an idea of whether the TCL/TK version of GNATS works
> fine.
> Please do give me what changes shld I make in the files and what
> are the files that gets
> affected. This is really a crucial thing for us now. We need it
> badly.
> -Uma
> -----Original Message-----
> From: S Ramesh [mailto:address@hidden
> Sent: Thursday, July 12, 2001 9:53 PM
> To: Uma R; GNATS
> Subject: Re: GNATSWEB installation
> Yeah even i faced more or less the same problem.
> but u tell me what version of linux u r using. then i can able to
> solve the problem. there are some steps u have to follow.
> reply..
> Ramesh
> On Thursday 12 July 2001 10:51 pm, Uma R wrote:
> > Hi there,
> >    There are problems in installing the gnatsweb interface. The
> > changes that needs to be done for the installation are
> > not clearly mentioned and everyone is facing problems in that.
> > Please can anyone give the steps for the installation clearly
> > so that it will make some help to others. Also I need to know
> > what a CGI enabled directory means in solaris because in linux I
> > created a directory in /home as /httpd/cgi-bin and things are
> > installed in that and the problem i face in linux is its says
> > that the connection is refused when i try to open the
> > page. In solaris the makefile itself fails. Can u pls do help me
> > and as i said this is really a critical thing for me and it shld
> > be done before the day.
> >
> > Thanks in advance,
> > Uma
> >
> > "Opportunity is missed by most people because
> > it is dressed in overalls and looks like work." - Thomas Edison
> ----------------------------------------
> Content-Type: application/ms-tnef; charset="iso-8859-1";
> name="winmail.dat"
> Content-Transfer-Encoding: base64
> Content-Description:
> ----------------------------------------

reply via email to

[Prev in Thread] Current Thread [Next in Thread]