[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: build: Maximum buffer size exceeded

From: Eli Zaretskii
Subject: Re: build: Maximum buffer size exceeded
Date: Sat, 08 Feb 2003 14:22:13 +0200

> From: Daniel Pfeiffer <>
> Newsgroups:
> Date: Sat, 8 Feb 2003 11:39:02 +0100
> When I think back I've never built Emacs with gcc 3.2 and no longer have
> 2.95.  I'm trying to build CVS (and meanwhile also 21.2) with gcc 3.2, glibc
> 2.2.5, Linux Kernel 2.4.19 (SuSE 8.1):
> ...
> Loading international/mule-conf.el (source)...
> Loading format (source)...
> Loading bindings (source)...
> Loading files (source)...
> Maximum buffer size exceeded
> make[1]: *** [bootstrap-emacs] Fehler 255

First, please note that reporting failures to build here is not
recommended: you should either report them on
(for released versions of Emacs), or to (for
CVS and pretest versions).  Many Emacs developers don't read this
forum, so they will never see your report.

> Even though I'm building it out of the box, I tried
> #define SYSTEM_PURESIZE_EXTRA 30000000
> to no avail.

The problem you see has nothing to do with SYSTEM_PURESIZE_EXTRA.
What Emacs is trying to tell you is that when it tried to load
file.el, it found that file to be more than 128MB, the maximum size of
a buffer Emacs can handle.  What you need to figure out is how come
files.el, which is only about 170KB, causes Emacs to think it's much

I don't have any idea why this would happen, except if something went
_very_ wrong when you downloaded the CVS version.  Please look closely
at files.el and see if it has some large piece of junk appended to it.
Deleting that file and doing a "cvs up -would bring you the current
versions of all the files from CVS, and fix the problem.

If the above doesn't help, please post your report to

reply via email to

[Prev in Thread] Current Thread [Next in Thread]