help-gnu-emacs
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Help for sql-oracle mode


From: Tim X
Subject: Re: Help for sql-oracle mode
Date: Fri, 29 Feb 2008 21:35:31 +1100
User-agent: Gnus/5.13 (Gnus v5.13) Emacs/23.0.60 (gnu/linux)

Misskiss <address@hidden> writes:

> Tim X <address@hidden> writes:
>
>>
>> Can you access the database just running SQL-Plus? Oracle is natorious
>> for providing misleading error messages. For example, you will get that
>> same error message if you specify the wrong SID. The first thing I wold
>> do is try 
>>
>> sqlplus DB1
>>
>> and hit enter when prompted for the username and password. If that
>> works, then we know the problem isn't with Oracle and have to look
>> closer at sqlplus. 
>>
>> Tim
>>
>> P.S.
>>
>> I've never seen an Oracle database that didn't require a username - the
>> username determines the schema - I guess you can have one, just never
>> come across it before. 
>> -- 
>> tcross (at) rapttech dot com dot au
>>
>
> Thanks a lot for the help! I tried "sqlplus DB1", it's the same problem,
> I still cannot login DB server. However, if I use a GUI tool to login
> the server, leave both user name and password as blank, I can login the
> server. It's really unconvininet for me... Is there any good solutions?
>
> Thanks a lot!
>

You could try starting sqlplus and then use its internal command to
connect to a database (sorry, can't remember exactly what its called and
I don't have sqlplus here). 

Another alternative would be to see if you can find out what/how the GUI
tool is doing it - possible if youhave the sources. 

Apart from that, I would try specifying just the schema name for the
username and a blank password. This might work as the username usually
determines what schema within the database instance you access. It could
be that if you don't specify a user, sqlplus doesn't know what schema to
log you into. Oracle is a bit different from other databases in that
different users normally have different schemas. To some extent, a
'database' in oracle speak is really an instance of the DBMS and each
schema is similar to what other DBMSs would call a database. I've worked
on sites where there is only one Oracle 'instance' which has many
'databases' and its the username that specifies the database. 

Of course, the real solution is to have a username and password. Its
extremely unusual to have an Oracle database without either. I actually
find it very unusual to be using Oracle and have a totally open
database. Its not the sort of DBMS you would use for trivial jobs and
most more serious jobs require som level of security. Are you certain
there is no username and password? Is it possible that the GUI tool you
use to access without one actually has a username/password configured
somewhere and it just uses that if you don't provide one?

The other thing to look at would be the sqlplus manual. Its possible
that there is a way to put stuff in the rc file that will make this
work. The other thing to look at is the database itself. Oracle has a
number of settings that control who can create sessions and limits on
those sessions. It is possible that the GUI tool uses a diffeent
connection method to sqlplus (Oracle supports many different connection
methods) and that you can only connect without a username/password if
you are using a specific method. If your not the DBA, then I would
definitely talk to the DBA regarding this. Oracle is a huge complex
beast and you really need to know how it has been configured for the
specific database your trying to use. 

HTH

Tim

> -- 
>
> You are always busy.
>
I'm usually busy procrastenating - very tiring!
>
>

-- 
tcross (at) rapttech dot com dot au


reply via email to

[Prev in Thread] Current Thread [Next in Thread]