[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: gdb with tramp problem

From: Joe Bloggs
Subject: Re: gdb with tramp problem
Date: Thu, 17 Jul 2008 20:29:56 +0100
User-agent: Gnus/5.11 (Gnus v5.11) Emacs/22.2 (gnu/linux)

Nick Roberts <address@hidden> writes:

>  > I did as you said, and I now get the correct buffer for the remote source 
>  > interacting with gud. I can set breakpoints in the source buffer and the 
> red
>  > dot appears in the margin. However, there is no indication of the current 
>  > line of execution, even when I step (C-x C-a C-n) from within the source 
> buffer.
>  > Also I dont see any tooltips after setting gud-tooltip-mode (I have 
> checked 
>  > gud-tooltip-modes to ensure c-mode is included).
> When I tried it using Emacs from CVS `C-x C-a C-n' worked but gud-tooltip-mode
> gave an error when Emacs tried to display a source file.  I've corrected that
> error now.
> I suspect there's still comething wrong with your setup.  Since Emacs 22
> includes Tramp, I don't know why you can't delete the version that you appear
> to have downloaded seaparately and just compile Emacs 22.2 normally.  I think
> this would solve the problem when stepping.  You would still need Emacs from
> CVS for GUD tooltips to work, of course.
> -- 
> Nick                                 

I couldn't get gdb to work with the version of tramp that comes with emacs 22,
that's why I installed the new version.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]