[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Tramp and BusyBox problem?

From: Mats Löfdahl
Subject: Re: Tramp and BusyBox problem?
Date: Tue, 17 Mar 2009 23:30:27 +0100
User-agent: Thunderbird (X11/20090105)

Michael Albinus wrote:
Mats Löfdahl <address@hidden> writes:

[I fear my answer from yesterday has been lost. Reposted, therefore.]

It was different this time. When I connected as mats (bash), I first
got the same uname error message as for root (BusyBox). But I knew
that it _had_ worked, so I tried again and got the ugly dired buffer.

So I did the same experiment with root in a fresh instance of
emacs. This generated the uname error but did _not_ work at the second

The debug buffers from the two sessions are here: - root/BusyBox - mats/bash

Looks like there is a race condition. Could you, please, check the
appended patch?

Sure. And thanks!

I applied the patch and byte-compiled tramp.el. Looks like I did it right:

address@hidden site-lisp]# diff tramp.el tramp.el.orig
< (when (not (tramp-get-connection-property proc "check-remote-echo" nil))
<       ;; No echo to be handled, now we can look for the regexp.
>     (when (or
>       ;; No echo to be handled, now we can look for the regexp.
>       (not (tramp-get-connection-property proc "check-remote-echo" nil))
>       ;; Sometimes the echo is invisible.
>       (not (re-search-forward tramp-echo-mark-marker nil t)))
address@hidden site-lisp]# ls -l tramp.el*
-rw-r--r-- 1 root root 303964 2009-03-17 23:19 tramp.el
-rw-r--r-- 1 root root 285934 2009-03-17 23:20 tramp.elc
-rw-r--r-- 1 root root 304070 2009-03-08 17:37 tramp.el.orig

I then started a fresh emacs and did the double attempt to connect as root. To me it looked just like last time but I've uploaded the debug buffer anyway:

reply via email to

[Prev in Thread] Current Thread [Next in Thread]