[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: tramp & numberp

From: Andrea Crotti
Subject: Re: tramp & numberp
Date: Tue, 26 Oct 2010 10:14:58 +0200
User-agent: Gnus/5.13 (Gnus v5.13) Emacs/23.2 (darwin)

> I've checked the Makefile, again. I have the impression, that the
> configure call did a wrong expansion of @abs_builddir@. Could you,
> please, adapt the setting in Makefile (line 36) by
> builddir        = /Users/andrea/Documents/pycon/tramp/lisp
> Afterwards, you must call "make" again.
> Best regards, Michael.

The bad news is that that variable is already correct, and nonetheless I
get the same error.

And I also tried on a linux 64 machine and it goes also wrong (another
path though).

--8<---------------cut here---------------start------------->8---
Opening output file: no such file or directory, 
--8<---------------cut here---------------end--------------->8---

It might be here the problem

--8<---------------cut here---------------start------------->8---
tramp-loaddefs.el: $(LISP_FILES)
# XEmacs must be advised to put tramp.el definitions at the beginning.
# We redefine `autoload-trim-file-name', therefore.
        $(EM) -l autoload                                                   \
          --eval "(setq generate-autoload-cookie \";;;###tramp-autoload\")" \
          --eval "(setq generated-autoload-file \"$@\")"                    \
          --eval "(setq make-backup-files nil)"                             \
          --eval "(unless (string-equal \"$(EMACS_INFO)\" \"emacs\")        \
                    (defalias 'autoload-trim-file-name                      \
                              'file-name-sans-extension))"                  \
          -f batch-update-autoloads $(builddir)
# XEmacs uses hard coded feature `lisp-autoloads'.
        @sed -e s/lisp-autoloads/tramp-loaddefs/g $@ >$@.$$$$ &&            \
          mv -f $@.$$$$ $@
# Emacs 22 does not add the `provide' form to the generated loaddefs.el.
        @grep -q provide $@ || echo "(provide 'tramp-loaddefs)" >>$@
--8<---------------cut here---------------end--------------->8---

but it's really strange that only to me it's not working, I might be
doing something wrong but.

--8<---------------cut here---------------start------------->8---
cd tramp
./configure --with-contrib
--8<---------------cut here---------------end--------------->8---

should not be too complicated right?

reply via email to

[Prev in Thread] Current Thread [Next in Thread]