[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: when building ./configure runs eternally

From: suvayu ali
Subject: Re: when building ./configure runs eternally
Date: Mon, 22 Aug 2011 20:57:04 +0200

2011/8/22 Алиса Безкреста <>:
> Hello
> I wanted to install emacs, so I ran ./configure.
> After a while it told me it has found an error of the kind: You seem to be
> running X, but no development libraries were found. You should bla bla bla.
> If you are sure you want Emacs compiled without X window support, pass
> --without-x to configure.
> So next I ran ./configure --without-x and I waited. After waiting a lot I
> started having the feeling of having a deja-vu experience. On the screen I
> was seeing things I had seen before. It seemed as if the machine was
> checking the same things round and round again. So I left the machine alone.
> When I returned after some hours its state was the same: checking round and
> round. I stopped it.
> After this, when I ran make, it told me: no targets specified and no
> makefile found
> What is happening?

You probably don't have all the development libraries installed.
Getting this list right and complete can be a bit tricky. If you are
on a redhat based system you can try

# yum-builddep emacs

to install them.

> Best regards
> Alisa Bezkresta



Open source is the future. It sets us free.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]