[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Groovy script that reads stdin fails with "

From: Barry Margolin
Subject: Re: Groovy script that reads stdin fails with " unknown protocol: c" when run with "shell-command-on-region"
Date: Thu, 12 Feb 2015 16:33:23 -0500
User-agent: MT-NewsWatcher/3.5.3b3 (Intel Mac OS X)

In article <address@hidden>,
 "KARR, DAVID" <address@hidden> wrote:

> I'm using Emacs in Cygwin on Win7.
> I have a Groovy script that reads from stdin, and it works fine when I run it 
> from Bash, piping text into the process.
> I'm now trying to select text in an Emacs buffer, and then execute 
> "shell-command-on-region"  The text I'm selecting appears to be identical to 
> what I'm sending on the command line.
> When I run this, it fails with " unknown 
> protocol: c".
> This obviously has something to do with my PATH, but I'm not sure what could 
> be wrong.  This might be more of a Cygwin question than an Emacs question.  I 
> tried going into my "*scratch*" buffer and printed out the PATH that the 
> process sees, and it obviously has entries in "/c/..." (I set my cygdrive 
> prefix to "c").

It doesn't sound like anything to do with the PATH. It sounds like 
something is generating a Windows filename of the form c:/pathname, and 
the script is treating that as a URL rather than a local filename. I 
guess it has something to do with the way that Emacs implements piping 
to a subprocess.

Barry Margolin, address@hidden
Arlington, MA
*** PLEASE post questions in newsgroups, not directly to me ***

reply via email to

[Prev in Thread] Current Thread [Next in Thread]