[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Emacs opens a file on startup - I cant figure out why??

From: Shlomi Vaknin
Subject: Re: Emacs opens a file on startup - I cant figure out why??
Date: Wed, 7 Sep 2016 13:09:05 -0700

Thanks Eli and Oscar, your replies helped me.

So I was recompiling, getting new binaries, checking my alias (which I do
use since unfortunately I am on OSX). And nothing seemed to help...

Until I realized that I tried some new "fancy" plugin in zsh, namely
"zsh-navigation-tools", and for some reason (or, somehow!) they bound $1 to
constantly be that file name, and my alias was "Emacs $@", so it was
opening that file...

I really dont get why or how that plugin did that, or what silly thing am I
missing..  For now I am removed that plugin, and life is back to normal..

Thanks for helping me out,

On Wed, Sep 7, 2016 at 10:36 AM, Shlomi Vaknin <>

> Hello all,
> I love to live in my emacs, and recently the strangest thing has happened
> to me.. While messing around with emacs, compiling it, messing with its
> configuration etc, I opened some file, and now that file buffer simply wont
> go away.. :P
> I have completly removed .emacs.d directory, completly reinstalled emacs,
> I am starting emacs like this:
> emacs -q --no-init-file  --no-desktop
> But still, the moment emacs is open, it opens this buffer! I tried to
> find/grep everywhere I could think of for that file name, but nothing comes
> up.... Nothing useful in *Messages* either.. Where could this come from?
> Any ideas???
> Thanks,
> Shlomi

reply via email to

[Prev in Thread] Current Thread [Next in Thread]