[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Tramp and sftp

From: Stephen Berman
Subject: Tramp and sftp
Date: Fri, 21 Apr 2017 12:07:21 +0200
User-agent: Gnus/5.13 (Gnus v5.13) Emacs/26.0.50 (gnu/linux)

For a long time I have been able to access a remote directory from Emacs
via the sftp protocol with Tramp.  I didn't pay any attention to how
this worked, since it just did.  But on a new system this has now
failed, and the reason seems to be that, although the system has dbus
installed, it has neither gvfs nor fuse, so the sftp invocation fails
with the error "Package `tramp-gvfs' not supported" (from
tramp-gvfs-file-name-handler).  When I invoke sftp from the shell, it
succeeds, so that protocol itself does not depend on gvfs or fuse.  I
tried removing sftp from tramp-gvfs-methods in the hope that this would
make tramp avoid using gvfs, but it didn't and access again failed.  I
then tried rebuilding emacs --without-dbus, but this resulted in the
message "Host ‘’ looks like a remote host, ‘sftp’ can only use
the local host".  So is there some way to access a remote directory from
Emacs via the sftp protocol without gvfs and fuse, or must I install
these and configure dbus accordingly?  (And if the latter, I'd be
grateful for any advice, since I've never done this; on the other system
that was evidently done by the distribution, on the new system I build
and configure all the packages myself.)

Steve Berman

reply via email to

[Prev in Thread] Current Thread [Next in Thread]